Eclipse installation, configuration and operation

This document aims to walk through the procedures to setup eclipse on different platforms for
java programming and to load in the course libraries for the course Introduction to Java
Programming.
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1. Setting up eclipse

Installing eclipse will require several steps, including installation of a java virtual machine (JVM),
downloading the correct version of eclipse and doing some configurations.

1.1 Operating system requirements

Microsoft Windows XP or later; Linux; Mac OS X 10.8 (Mountain Lion) or later



1.2. Installing the java virtual machine (JVM)

A java virtual machine (JVM) is required to run any java program. Eclipse, which is also a java
program, also runs on a java virtual machine. To obtain a JVM, you can install either a Java
runtime environment (JRE) or a Java development toolkit (JDK). JDK is recommended as it
provides additional resources and tools for developing java programs. For Linux users, you can
install OpenlDK instead of JDK to avoid the various steps of setting up JDK on your machine.
You can jump to the next step if you have already installed JRE or JDK on your machine.

You can download JRE from:

http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html

Java SE Runtime Environment 8u45
You must accept the Oracle Binary Code License Agreement for Java SE to download this

Check this option software.
=) Accept License Agreement '® Decline License Agreement

Product / File Description File Size Download
Linux x86 41.34 MB  jre-8u45-linux-i586.rpm
Linux x86 6263 MB  jre-8u45-linux-i586.tar.gz
Linux x64 39.51 MB  jre-8u45-linux-x64.rpm
Linux x64 60.8Y MB  jre-8u45-linux-x64.tar.gz
Mac OS X x64 5771 MB  jre-8ud5-macosx-x64.dmg
Mac OS X x64 536 MB  jre-8u45-macosx-x64.tar.gz
Solaris SPARC 64-bit 46.06 MB  jre-8ud5-solaris-sparcv9.tar.gz
Solaris x64 495 MB  jre-8u45-solaris-x64.tar.gz
Windows x86 Online 0.54 MB  jre-8u45-windows-i586-iftw.exe
Windows x86 Offline 356 MB  jre-Bud5-windows-i586.exe
Windows x86 5257 MB  jre-Bu45-windows-i586.tar.gz
Windows x64 41189 MB  jre-8u45-windows-x64.exe
Windows x64 556 MB  jre-8u45-windows-x64.tar.gz

For installer of JRE 7, please refer to here.
Disclaimer:

Oracle has announced the end of public updates for JRE 7. Future updates for JRE 7 might not be
available.


http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html
http://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-1880261.html

or JDK from:

http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

Java SE Development Kit 8u45

You must accept the Oracle Binary Code License Agreement for Java SE to download this

Check this option software.
‘ Accept License Agreement '®' Decline License Agreement

Product / File Description File Size Download
Linux x86 14689 MB  jdk-Bud5-linux-i586.rpm
Linux x26 166.88 MB  jdk-Bud5-linux-i586.tar.gz
Linux x64 14519 MB  jdk-Buds-linux-x64.rpm
Linux xB4 16524 MB  |dk-Bud5-linux-x64 tar.gz
Mac OS5 X x64 22198 MB  jdk-Bud5-macosx-x64 dmg
Solaris SPARC 64-bit (SVR4 package) 131.73MB  |dk-Bud5-solaris-sparcvd tar 7
Solaris SPARC 64-bit 929 MB  |dk-Bud5-solaris-sparcv.far.gz
Solaris x64 (5VR4 package) 13951 MB  |dk-Budb-solaris-x64 tar .2
Solaris x64 9588 MB  jdk-8udb-solaris-x64 tar.gz
Windows x86 17597 MB  jdk-Budb-windows-i586 exe
Windows x64 18042 MB  jdk-BudS-windows-x64 exe

For installer of JDK 7, please refer to here.
Disclaimer:

Oracle has announced the end of public updates for JDK 7. Future updates for JIDK 7 might not be
available.

Please check “Accept License Agreement” before downloading. You will then need to choose
which version to download according to your platform. A 32 bit JRE/JDK is required for 32 bit
operating system while a 64 bit JRE/JDK is required for 64 bit operating systems. For Mac users,
you will need to have Mac OS X 10.8 (Mountain Lion) or later on your machine and you can only
download 64 bit JRE/JDK.

1.3. Downloading eclipse

After installing the correction of JRE/JDK, you can download eclipse by choosing “Eclipse IDE for
Java Developers” from the following website:

https://www.eclipse.org/downloads/

Again, you will need to choose the download according the type and architecture of your
platform.


http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html
http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html
https://www.eclipse.org/downloads/

Eclipse Luna SR2 (4.4.2) Release for «

Eclipse IDE for Java Developers, 155 e
Downloaded 3,640,642 Times Windows 32 Bit

Windows 64 Bit
The essential tools for any Java developer, including a Java IDE, a CVS client,

Git client, XML Editor, Mylyn, Maven integration...

Eclipse IDE for Java EE Developers z541ve
s Downloaded 1,945,190 Times Windows 32 Bit

5 ) — ) ) Windows 64 Bit
Tools for Java developers creating Java EE and Web applications, including a

Java IDE, tools for Java EE, |PA, JSF, Mylyn...

Enterprise-Class BIRT Report Server (Free, Not a Trial)

S Instantly enhance your Eclipse BIRT reports with interactive, real-time
K“ analytics that can be seamlessly embedded into web and mobile apps.

After downloading, you can decompress the downloaded file to a location of your choice.
Eclipse can then be launched by executing “eclipse.exe” in the decompressed folder. You will be
prompted to choose a workspace for saving your java projects on the first run. Browse a
directory of your choice and check “Use this as the default and do not ask again”. After eclipse
has started up, close the welcome screen.
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Select a workspace

Eclipse stores your projects in a folder called a workspace.
Choose a workspace folder to use for this session.

Workspace: Ch\Users\lecfan\workspace -

Use this as the default and do not ask again




1.4. Advanced configuration (Optional)

1.4.1. Having multiple JRE/IDKs

If multiple versions of JRE/JDK are installed on the computer, eclipse would not be able to
decide which version to use. To select a desire version, Click on “Windows “ -> “Preferences” ->
Expand the “Java” node, and click on “Installed JREs”. If the list is not showing the JRE/JDK you
wish to use, you can add it by clicking “Add” -> “Standard VM” and specify the JRE home folder.
After that, click “Finish”. After checking the added JRE/JDK in the list of “Installed JREs”, restart
eclipse. The configuration on JRE/JDK is then done.
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1.4.2 Viewing source code (JDK required)

Sometimes it would be useful to view the source code of java classes. To do this, we need to
attach the source code to the JRE/JDK that we are using. Click on “Windows” -> “Preferences” -
> Expand the “Java” node, and click on “Installed JREs”. Select the JRE/JDK that you are using
and click “Edit”. A dialog pops up showing a list of JRE system libraries. Select “rt.jar” and click

“Source Attachment”.

i
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JRE Definition
Specify attributes for a JRE
JRE home: C:\Program Files (x86)\Java\jrel 8.0_40
JRE name: jrel 8040

Default VM arguments:

JRE system libraries:

[> @1 ChProgram Files (x86)\ava'jrel B.0_400ib\resources,jar
i |[md C:\Program Files (x86)\Java\jrel 8.0_40\lib\rt.jar |
C:\Program Files (x86)%)ava'jrel 8.0_40\ib'jsse.jar
C:\Program Files (x86)\Java'jrel B.0_40\ib\jcejar
ChProgram Files (x86)\ ) ava'jrel 8.0_400lib\charsets,jar
Ch\Program Files (xB6)\ ) ava'jrel B.0_400likjfr.jar
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C:\Program Files (x86)\Java\jrel 8.0_400ib\exth\cldrdata.jar
ChProgram Files (k86 ava'yrel B.0_400]ib\exth dnsns.jar
Ch\Program Files (x86)\ava'jrel B.0_400ib\extjaccess,jar
C\Program Files (x86])%Java'jrel B.0_40\ b exthjfart jar
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Check “External location” and browse to the JDK folder. (e.g. jdk1.8.0_XX). There should be a
compressed file named “src.zip”. Close all the dialogs by confirming them. Later, you will be
able to view the source code of java classes by highlighting them, right click, and choose “Open

Declaration”.
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2. Working environment setup

There are three frequently used components in the eclipse work space. The blank area in the
center is the coding area where you type your code. You can start typing code on it after you
have created a project and the source files, which will be explained later. The second
component is the Console where you can do standard input and output. If you do not see it,
you can click “Window” -> “Show View” -> “Console” to bring it up. The “Package Explorer” is
also important for managing the java projects in your workspace. Again, if you cannot see it,
you can bring it up by clicking “Window” -> “Show View” -> “Package Explorer”.
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3. Basic operations

3.1 Creating java projects and source files

To create a java project, click “File” -> “New” -> “Java Project”. A dialog will show up asking you
for the name of the project. After inputting a name, you can keep the other settings as default
and click “Finish”.
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To create a source file for the project, you can select the project on the “Package Explorer” and
click “File” -> “New” -> “Class”. A dialog will show up asking you for the name of the class. After
inputting a name, you can keep the other settings as default and click “Finish”.
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You can then start coding.



3.2 Executing a program

Suppose we have code up a program and we want to run it. To do this, we can select the source
file in the “Package Explorer” and click “Run” -> “Run”. Alternatively, you can select the source
file and then hit the green “play” button just under the menu bar to run the program.

w0

Notice that it is required to have a main method in the source file that you are running.
Otherwise, eclipse will run the last source file with a main method it has run or it will complain
that it cannot find a main method.

3.3 Importing java project

Suppose that you wish to work on another computer. You will then need to copy the project
folder in the workspace that you are working on in the original computer, transfer it to another
computer and import it using eclipse. To import the transferred project, you can click “File” ->
“Import” -> expand “General” -> select “Existing Projects into Workspace” and click “Next”. You
can then select the root directory of the project by browsing. After selecting, you can keep the
other settings as default and click “Finish”. The project is then imported.
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3.4 Switching workspace

Sometimes, you would like to switch between different workspace for better management of
the projects. To do this, you can click “File” -> “Switch Workspace” -> “Other”. Then you can
browse to your desire workspace and click “OK”. Eclipse will then restart. After restarting, it will
operate in the new workspace. Notice that the working environment will also be changed
according to the workspace, some of the previously hide panels might re-appear.
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= Workspace Launcher @

Select a workspace

Eclipse stores your projects in a folder called a workspace.
Choose a workspace folder to use for this session.

Workspace:  Ch\Usershleofan'\Desktop\MyWorkSpace - Browsze...

» Copy Settings ]

'r'-?\' OK ] I Cancel




4. Using libraries

It is often that we need to use functions provided by third party libraries to complete our goal.
To use a library in a specific project, we first need to copy the library to the project folder in the
workspace. A good practice would be to create a subfolder in the project folder named “lib”
and put all the required third party libraries inside. We will then need to confirm if the added
libraries are visible to eclipse by checking the project in the “Package Explorer”. If you cannot
see the libraries, try right clicking on the project in the click “Refresh”. Select the project in the
“Package Explorer” and then click “Project” -> “Properties” -> select the “Java Build Path” node
-> select the “Libraries” tab. Click “Add JARs” and browse for the libraries you would like to use.
After hitting “OK” to confirm the dialogs, the libraries are imported successfully.
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5. Javadoc generation (JDK required)

It is always a good practice to generate the documentation of the programs we have written so
that others can understand how to use it properly. After coding our program with javadoc style
comments, we can generate a corresponding web page as the documentation of the program.
To do so, select the program in the “Package Explorer”, click “File” -> “Export” -> expand the
“Java” node -> select “Javadoc” and click “Next”. If the “Javadoc command” is empty, you will
need to configure the location of the command by browsing to the folder where the jdk is
installed: e.g.” C:\Program Files\Java\jdk1.8.0_XX\bin\javadoc.exe”. After this time, eclipse will
remember the location of the command and you don’t need to configure it again. You can then
select a desire location for exporting the documentation and click “Finish”. The default is a
folder named “doc” in the project folder in the work space. If you encounter a dialog on
“Update Javadoc Location”, click “Yes To All”.
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After that you can browse to the “doc” folder in the project folder in the workspace and open
“index.html|” to view the documentation.
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